2 複数のファイルを使用する

2.1 (タブと一緒に)プロジェクトを作る

現在のTextMateのバージョン(1.5)では、ファイルタブはプロジェクトが作成されているときのみサポートされています。幸運なことに、プロジェクトを作成するのは簡単です。つまり→ New Project (⌃⌘N)を選択するだけです。

これで下のようなウインドウが開きます。

Project Window

ファイルを(プロジェクト)ドロワにドラッグするか、(ギアのアイコンがついた)プロジェクドロワアクションメニューから、“Add Existing Files…”を使うことによってファイルを追加することが可能です。

プロジェクトを作成する別の方法は、複数のファイルを直接(例えば、Dockにある)TextMateアプリケーションアイコンにドラッグすることです。これは、これらのファイルからなる新しいブロジェクとを作成する近道です。

もうひとつのたいしたことのない詳細は、このようにプロジェクトを作成すると、プロジェクトを閉じるときに、プロジェクトを保存したいかどうかを尋ねられないということです。

プロジェクトを保存すること利点は、(例えばどのファイルが開いていたかという)状態を保全でき、すぐに特定のファイル群を開くことができることにあります。もし、TextMateを修了するときに(保存された)プロジェクトを開いたままにしておくと、そのプロジェクトは次にTextMateを起動したときに自動的に開きます。

またターミナルからプロジェクトを作ることも可能です。たとえば、mateシェルコマンドをつかって。

2.1.1 自動的にアップデートするプロジェクト

プロジェクトがディスクにあるファイルとフォルダーを模倣するためには、フォルダーをTextMateのアプリケーションアイコンかプロジェクトドロワにドラッグすることもできます。

TextMateはディスクでの変化にあわせてフォルダの中身を自動的にアップデートする、フォルダレフェレンス (folder reference)を作ります。

Project Window With Tabs

現在のところ、アップデートはTextMateにフォーカスが戻ったときにされ、ネットワーク上のマウントされたディスクでは遅いかもしれません。その場合は、プロジェクトに追加したいファイルのみを追加し、解決した方がいいかもしれません。(追加されたファイルはディスクでの構造をまねるために手動でグループ化し並び替えることもできます。)

この、ネットワーク上のマウントされたディスクでの更新の遅れについては、将来のリリースで解決される予定です。

2.1.2 必要ないファイルをフィルタリングする

フォルダレフェレンスを使っているとき、あなたはある個別のファイルやフォルダをプロジェクトから除外したいとおもうかもしれません。これは、Preferences → Advanced → Folder Referencesの中にあるファイルとフォルダのパタンを変えることによって可能です。

Folder Reference Patterns

それぞれのファイルとフォルダの完全なパスにマッチする正規表現があります。もしそのパタンがアイテムとマッチしたら、そのアイテムは含まれます。そうでなければ、除外されます。これを反対にするためには、つまりマッチしたものをプロジェクトから除外するには、感嘆符(!)をパタンの前につけます。

パタンは新しいフォルダを作るときだけ使われます。現在のフォルダレファレンスには、プロジェクトドロワの中のフォルダレフェレンスを使うことができ、プロジェクトドロワの(文字を丸で囲んだIという)インフォボタンを使い、パタンを編集することができます。

このシステムの複雑さは将来のバージョンで解決される予定です。

2.1.3 テキストファイルとバイナリファイル

プロジェクトドロワのファイルはシングルクリックもしくはダブルクリックすることができます。もしシングルクリックをして、そのファイルのタイプがテキストであれば、そのファイルはメインウインドウのタブで開きます。

Tab Bar

もしファイルをダブルクリックすると、そのファイルはデフォルトのアプリケーションで開きます。フォルダーもダブルクリックされることがができることを覚えておいてください。例えばInterface Builderのnibファイルはフォルダとして表示され、ダブルクリックされることができ、(そして、Interface Builderで開きます。)

前述のように、テキストファイルのみがメインウインドウで、シングルクリックされたときに開かれます。TextMateが、ファイルがテキストかどうかを判断する方法は、ファイルの拡張子によってです。 - もし拡張子が不明の場合ファイルの最初の8 KBを読み、それが有効な(ASCIIの上位集合である)UTF-8であるかどうかをチェックします。

もしTextMateがあなたのファイルを開かず、そのファイルがアクションメニューを表示させる拡張子を持っている場合、その最後に以下のように表示されるはずです。Treat Files With “.«ext»” Extension as Text (".«ext»"拡張子をもつファイルをテキストとして扱う)

2.1.4 プロジェクトドロワのポジショニング

デフォルトでは、プロジェクトドロワはプロジェクトウインドウの左側に開きます。もし左側に十分なスペースがない場合は、右側に開きます。この設定は固定されます。なので、どちら側でドロワが最後に開いたかを記憶します。

Project Drawer

左側に戻すためには、いったんドロワを閉じ、(View → Hide Project Drawer)、それから右側にスペースがないようにプロジェクトウインドウを移動させます。それから、ドロワを再度開きます。そうすればまた左側に開きそれが新しいデフォルトとなります。

右側に強制的に開きたいばあいはその反対を行ってください。

2.2 プロジェクト内での検索と置換

Edit → Find → Find in Project… (⇧⌘F) を使って下にあるようなウインドウを表示させることができます。

Find In Project

ここから現在のプロジェクトのなかのすべての(テキスト)ファイルを検索し置換することができます。Findを押した後、Replace All(全て置換)もしくはどのマッチが置換されるべきかを選択することができます。その場合には、Replace AllボタンはReplace Selectedに変わります。

現在のところ、プロジェクト全体の全てのテキストファイル以外の何かに検索の対象をしぼる事はできます。事前策としては、もしあなたがプロジェクトのサブセットだけを検索したい場合、あなたはプロジェクトドロワのなかのファイルを選択して、その選択をTextMateのアプリケーションアイコンにドラッグして、全く新しいプロジェクトを作ることができます。検索/置換はそのプロジェクトで実行され、そのあと閉じることができます。

2.3 優雅にファイル間を移動

プロジェクトで作業をしているとき、開いているファイル間を移動する2、3の方法があります。

もっとも簡単な方法はあなたが使うファイルのタブをクリックすることです。また、キーボードからは⌘1から9を押すことで可能です。ファイルタブの1から9へスイッチできます。

またあなたは、現在のタブの左か右のファイルのタブを選択するためには⌥⌘← と ⌥⌘→を使うことができます。

マウスを使ってファイルタブ並べ直すことが可能です。(タブの上でマウスボタンをクリックしホールドして、その後、新しい場所へドラッグします。)このようにして、キーボードでのスイッチングがより自然になるように、並び替えることができます。

もう一つのキーが⌥⌘↑です。現在のファイルと同じベースネームをもったファイルのテキストファイルへの移動を繰り返します。これは、主にインターフェイスファイル(ヘッダ)と実装ファイル(ソース)をもつ言語での作業で役に立ちます。

もし開いていないファイルへ移動したい場合、NavigationメニューにあるGo to File…(⌘T)アクションを使うことができます。これは、下のようなウインドウを開きます。

Go To File

このウインドウは最後の使用に従って、プロジェクトの全てのテキストファイルのリストを表示します。つまり、リターンを押すとあなたが最後に使用したファイルへ移動します。このように使うと、最近使ったファイルへ簡単に移動できます。

あなたは表示されるファイルの数を少なくするためにフィルタ文字列を入力することができます。このフィルタ文字列は省略形としてファイルネームに対してマッチします。それでファイルは与えられた省略形に対してどのくらいよくマッチするかによって並べ替えられます。例えば、上の画像ではフィルタ文字列はotvです。それでTextMateはOakTextView.hがベスとマッチだと(一番上に表示することによって)決めています。

私が必要としているファイルは#2にランクしているOakTextView.mmです。しかし、私はすでに過去に修正したので、TextMateはこれがotvというフィルタ文字列とうまくいくマッチだと学びます。つまり、これは適応/順応的であり、あなたの使い方のパタンから学びます。[ActivatingBundleItems]: bundles#activationofbundle_items